PHP libera nuevas versiones. Supone el final de la rama 5.2

Se han publicado recientemente nuevas versiones de PHP (versiones 5.2.14 y 5.3.3) que solucionan múltiples problemas de seguridad, que podrían permitir evitar restricciones de seguridad, provocar denegaciones de servicio, obtener información sensible o comprometer los sistemas afectados.

Además, según han anunciado los desarrolladores de PHP, los usuarios de la versión 5.2 (liberada hace casi 4 años) deberían actualizar sus servidores a la 5.3. Este hecho es debido a que el soporte activo de la rama 5.2 termina con la última versión liberada: 5.2.14.

Si concretamos en los errores solucionados según la rama de PHP afectada, la versión 5.2.14 soluciona en torno a 60 errores relaciondos con riesgos de seguridad como fallos de memoria en el tratatamiento de strings.

La versión 5.3.3, soluciona 100 errores  relacionados con posibles buffer overflows en el driver MySQL.

Comparte este artículo:

No hay comentarios a este artículo

Sé el primero en enviar un comentario: