Problemas y recomendaciones cuando actualices a WordPress 4.5

Problemas y recomendaciones cuando actualices a WordPress 4.5

Si utilizas WordPress como gestor de contenidos en tu página web, seguramente te haya salido un mensaje avisándote de que deberías actualizar a la versión 4.5 del famoso CMS.

Wordpress 4.5

Esta nueva versión introduce ciertas mejoras como:

  • Vista previa responsive y logo del tema en el Personalizador
  • Nuevos atajos de formato en el editor
  • Edición de enlaces inline
  • Mejoras en los correos electrónicos de moderación de comentarios
  • Mejoras en la carga y gestión de imágenes (renderizado más rápido)
  • Acceder a WordPress con usuario o correo electrónico

Problemas detectados

Durante estos días hemos recibido consultas en nuestro Departamento de Soporte Técnico por parte de clientes que, tras actualizar el WordPress que utilizan en su página web a la última versión, su página ha dejado de funcionar. Teniendo que hacer un rollback de su sitio web para resolver la incidencia.

El problema es debido a que estos usuarios utilizan el plugin Visual Composer para diseñar su página web. O su web está basada en un tema que trabaja con dicho plugin o Divi (tema y constructor). Estos componentes están basados en una libreria previa de jQuery, que trabaja con una sintaxis diferente, y no es compatible con la versión de jQuery (la 1.12) que ha empezado a utilizar la versión 4.5 de WordPress. Visual Composer ya ha publicado una revisión que hace que este plugin sea compatible con la nueva versión WordPress 4.5.

Posiblemente no seas consciente de que utilizas el plugin Visual Composer o Divi. Esto es debido a que la mayoría de los temas premium que se venden en sitios como ThemeForest, incorporan la descarga del plugin Visual Composer y/o un maquetador como Divi. Es con estos componenetes con los que al final los usuarios crean sus páginas, portada y muchos más contenidos.

Tras actualizar, también se han dado casos que han afectado a la resolución y calidad de las imágenes, causado por un cambio en la compresión por defecto de las imágenes. Si utilizas plugins de optimización de imágenes, como Optimus, seguramente tus imágenes con extensión .jpg ya están optimizadas y no deberían verse afectadas.

Por último, otros clientes han detectado que de repente les han empezado a salir mensajes de advertencia en su sitio web o en el log de errores de su espacio de hosting. Esto es debido a que WordPress 4.5 deja activada la funcionalidad de mostrar mensajes de aviso (warning), hecho que sólo debería ocurrir si tienes habilitado el modo «debug». Por lo tanto, comprueba que tienes desactivada la visualización de errores de PHP (display_errors) y que el modo «debug» está desactivado (WP_DEBUG en fichero wp-config.php).

Recomendaciones

Antes de realizar cualquier actualización de WordPress te recomendamos:

  • Hacer una copia de seguridad completa de nuestro sitio web: ficheros y bases de datos.
  • Comprobar que el tema y plugins que utilizas es compatible con la nueva versión.
  • Elige siempre temas y plugins con un historial de actualizaciones fiable y constante.
  • Deshabilita plugins que no utilices.
  • Tener todos los plugins y temas actualizados a la última versión.

Comparte este artículo:

No hay comentarios a este artículo

Sé el primero en enviar un comentario: