Vulnerabilidad en librería glibc afecta a WordPress y aplicaciones PHP

Se ha detectado una vulnerabilidad grave en la librería glibc que afecta a la mayoría de los servidores con sistema operativo Linux. La vulnerabilidad, denominada como GHOST (CVE-2015-0235), permite acceso local y remoto a la función de sistema gethostbyname. De esta forma, cualquier atacante podría ejecutar aplicaciones y adquirir el control completo del servidor.

Vulnerabilidad GHOST - glibc

Las versiones de glibc afectadas son:

  • glibc 2.2 a 2.17 (incluidas) son vulnerables
  • glibc 2.18 a 2.20 (incluidas) NO son vulnerables
  • las versiones anteriores de glibc (<= 2.1.3) NO son vulnerables

Los principales fabricantes de distribuciones Linux como RedHat (CentOS), Debian y Ubuntu ya han actualizado su software contra la vulnerabilidad GHOST.

WordPress, otros CMS y aplicaciones PHP afectadas

Esta vulnerabilidad afecta a aplicaciones PHP y CMS que hagan uso de la función gethostbyname.

Según investigadores de la vulnerabilidad GHOST, ésta puede afectar de forma especial al CMS WordPresss. La función wp_http_validate_url() utiliza esta librería para validar cada petición de pingback.

Como solucionar la vulnerabilidad

Nuestras recomendaciones son:

  1. Actualizar los sistemas (mediante el comando yum update – RedHat, CentOS – o apt-get update – Debian, Ubuntu -. Una vez aplicadas las actualizaciones, es necesario reiniciar el servidor.
  2. Si no es posible aplicar las actualizaciones de la librería glibc, en el caso concreto de WordPress, se recomienda deshabilitar el pingback remoto y la edición remota mediante XMLrpc. Existen plugins que nos permiten deshabilitar XMLrpc. Si queremos deshabilitar el pingback remoto deberemos añadir el siguiente código al fichero functions.php:
add_filter( 'xmlrpc_methods' , function( $methods' ) { unset( $methods[ 'pingback.ping ] ); return $methods; } );

Comparte este artículo:

No hay comentarios a este artículo

Sé el primero en enviar un comentario: